WRF and JRA-25 data

Any issues with the actual running of the WRF.

WRF and JRA-25 data

Postby Abacab » Thu Aug 30, 2012 9:03 pm

Hello!
I'm trying to make some simulations using the global JRA-25 data.

I got pass throught the execution of GEOGRID and UNGRIB, but getthing some problems onthe excutions of the METGRID, as shown bellow...
but I get the error when running metgrid:
--------------------------------------------------------------------------
Oops, something is not right with the Gaussian latitude computation.
The input data gave the starting latitude as 89.292.
This routine computed the starting latitude as +- 89.142.
The difference is larger than 0.01 degrees, which is not expected.
ERROR: Gaussian_latitude_computation
--------------------------------------------------------------------------

I think that I found this error in ungrib, during unpack
data from fcst_phy2m.YYYYMMDDCC.grb (YYYY-year, MM - month,DD -day of month, CC - hour of day).
From JRA-25 description: fcst_phy2m: Grid Description: 1.125° x ~1.125°, from 0E to 358.875E and 89.142N to 89.142S (320 x 160 Gaussian Longitude/Latitude).

Also I found in archive similar problem at
http://mailman.ucar.edu/pipermail/wrf-u ... 00416.html

But now I have not error with nnrp-data. WRF work well with NNRP.
In <http://www.mmm.ucar.edu/wrf/users/wpsv2/known-prob.html> I read that "This is a bug in ungrib to degrib Gaussian data"
in gridcode.F90 (an error may occur when running metgrid.exe: ERROR: Gaussian_latitude_computation).


Does anyone have suggestions on what?
Thanks,
Abacab
 
Posts: 5
Joined: Wed Mar 17, 2010 10:34 pm

Re: WRF and JRA-25 data

Postby dcvz » Fri Aug 31, 2012 2:53 am

According to http://rda.ucar.edu/datasets/ds625.0/#docs the grid metadata were encoded incorrectly by JMA in the 320x160 files. This would cause the metgrid problem you are seeing. NCAR has corrected the grid info in their files. You should use their data. Otherwise, you would have to hard-wire the correct values into ungrib yourself.
dcvz
 
Posts: 198
Joined: Tue Apr 15, 2008 12:02 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 13 guests