Page 1 of 1

ERROR - MPI_COMM_WORLD (WRF.EXE)

PostPosted: Mon Jun 10, 2019 12:03 am
by ikhsanmurad90
Dear team,
I have an error during running WRF.

taskid: 0 hostname: localhost.localdomain
module_io_quilt_old.F 2931 F
Quilting with 1 groups of 0 I/O tasks.
Ntasks in X 1 , ntasks in Y 2
WRF V4.0 MODEL
*************************************
Parent domain
ids,ide,jds,jde 1 100 1 103
ims,ime,jms,jme -4 105 -4 58
ips,ipe,jps,jpe 1 100 1 51
*************************************
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 681047320 bytes allocated
med_initialdata_input: calling input_input
Input data is acceptable to use: wrfinput_d01
Timing for processing wrfinput file (stream 0) for domain 1: 0.66683 elapsed seconds
Max map factor in domain 1 = 1.00. Scale the dt in the model accordingly.
INPUT LandUse = "MODIFIED_IGBP_MODIS_NOAH"
LANDUSE TYPE = "MODIFIED_IGBP_MODIS_NOAH" FOUND 33 CATEGORIES 2 SEASONS WATER CATEGORY = 17 SNOW CATEGORY = 15
INITIALIZE THREE Noah LSM RELATED TABLES
Skipping over LUTYPE = USGS
LANDUSE TYPE = MODIFIED_IGBP_MODIS_NOAH FOUND 20 CATEGORIES
INPUT SOIL TEXTURE CLASSIFICATION = STAS
SOIL TEXTURE CLASSIFICATION = STAS FOUND 19 CATEGORIES
*********************************************************************
* PROGRAM:WRF-Chem V4.0 MODEL
* *
* PLEASE REPORT ANY BUGS TO WRF-Chem HELP at *
* *
* wrfchemhelp.gsd@noaa.gov *
* *
*********************************************************************
Timing for Writing wrfout_d01_2018-04-01_00:00:00 for domain 1: 0.94290 elapsed seconds
open_aux_u : error opening auxinput5_d01_2018-04-01_00:00:00 for reading. 100
Input data processed for aux input 5 for domain 1
Input data is acceptable to use: wrfbdy_d01
Timing for processing lateral boundary for domain 1: 0.26993 elapsed seconds
WRF NUMBER OF TILES FROM OMP_GET_MAX_THREADS = 4
Tile Strategy is not specified. Assuming 1D-Y
WRF TILE 1 IS 1 IE 100 JS 1 JE 13
WRF TILE 2 IS 1 IE 100 JS 14 JE 26
WRF TILE 3 IS 1 IE 100 JS 27 JE 38
WRF TILE 4 IS 1 IE 100 JS 39 JE 51
WRF NUMBER OF TILES = 4
Fatal error in PMPI_Cart_create: Invalid argument, error stack:
PMPI_Cart_create(319).....: MPI_Cart_create(MPI_COMM_WORLD, ndims=2, dims=0x7ffea4b1b830, periods=0x2a18e930, reorder=0, comm_cart=0xa7ddd20) failed
MPIR_Cart_create_impl(194):
MPIR_Cart_create(58)......: Size of the communicator (2) is smaller than the size of the Cartesian topology (4)



I don't know how to solve it. I'm using the WRFV4.0

Re: ERROR - MPI_COMM_WORLD (WRF.EXE)

PostPosted: Wed Oct 07, 2020 3:03 pm
by slekaw
Hi,

Hopefully you've already fixed your issue. I just ran into this myself, and changed nproc_x and nproc_y both to -1 in the namelist.input, which resolved my particular issue. Maybe that will help you.