"very high topography" problem with running real.exe

Any issues with the actual running of the WRF.

"very high topography" problem with running real.exe

Postby lmkli » Mon Jan 20, 2020 11:31 am

Hello,

When I ran real.exe, I got such kind of error information:

----- ERROR: The reference pressure is not monotonically decreasing
This tends to be caused by very high topography
(i,j) = 161 1415, topography = 6642.646 m
k = 13, reference pressure = 39188.96 Pa
k = 14, reference pressure = 39218.90 Pa
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 1238
In the dynamics namelist record, reduce etac from 0.2000000
-------------------------------------------

Any help? Thanks in advance.

Below is the namelist.input

&time_control
run_days = 8,
run_hours = 0,
run_minutes = 0,
run_seconds = 0,
start_year = 2019, 2000, 2000,
start_month = 11, 01, 01,
start_day = 01, 24, 24,
start_hour = 12, 12, 12,
start_minute = 00, 00, 00,
start_second = 00, 00, 00,
end_year = 2019, 2000, 2000,
end_month = 11, 01, 01,
end_day = 09, 25, 25,
end_hour = 12, 12, 12,
end_minute = 00, 00, 00,
end_second = 00, 00, 00,
interval_seconds = 10800
input_from_file = .true.,.true.,.true.,
history_interval = 180, 60, 60,
frames_per_outfile = 1, 1000, 1000,
restart = .false.,
restart_interval = 5000,
io_form_history = 2
io_form_restart = 2
io_form_input = 2
io_form_boundary = 2
debug_level = 0
auxinput4_inname = "wrflowinp_d<domain>"
auxinput4_interval = 180
io_form_auxinput4 = 2
/

&domains
time_step = 16,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 1,
e_we = 2289, 112, 94,
e_sn = 1887, 97, 91,
e_vert = 33, 30, 30,
p_top_requested = 5000,
num_metgrid_levels = 27,
num_metgrid_soil_levels = 4,
dx = 4000, 10000, 3333.33,
dy = 4000, 10000, 3333.33,
grid_id = 1, 2, 3,
parent_id = 0, 1, 2,
i_parent_start = 1, 31, 30,
j_parent_start = 1, 17, 30,
parent_grid_ratio = 1, 3, 3,
parent_time_step_ratio = 1, 3, 3,
feedback = 1,
smooth_option = 0
/
max_dz = 1050.

&physics
mp_physics = 3, 3, 3,
ra_lw_physics = 1, 1, 1,
ra_sw_physics = 1, 1, 1,
radt = 30, 30, 30,
sf_sfclay_physics = 1, 1, 1,
sf_surface_physics = 2, 2, 2,
bl_pbl_physics = 1, 1, 1,
bldt = 0, 0, 0,
cu_physics = 1, 1, 0,
cudt = 5, 5, 5,
isfflx = 1,
ifsnow = 1,
icloud = 1,
surface_input_source = 3,
num_soil_layers = 4,
num_land_cat = 21,
sf_urban_physics = 0, 0, 0,
sst_update = 1
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1, 1, 1,
km_opt = 4, 4, 4,
diff_6th_opt = 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12,
base_temp = 290.
damp_opt = 0,
zdamp = 5000., 5000., 5000.,
dampcoef = 0.2, 0.2, 0.2
khdif = 0, 0, 0,
kvdif = 0, 0, 0,
non_hydrostatic = .true., .true., .true.,
moist_adv_opt = 1, 1, 1,
scalar_adv_opt = 1, 1, 1,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,.false.,
nested = .false., .true., .true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/
lmkli
 
Posts: 4
Joined: Tue Feb 03, 2009 5:51 pm

Re: "very high topography" problem with running real.exe

Postby dcvz » Wed Jan 22, 2020 8:56 pm

The default values for the auto_levels variables in real are not designed for such extreme cases. You can either play with the settings (max_dz, dzbot, dzstretch_s, dzstretch_u) or explicitly set the eta levels using eta_levels= 1.0,...,0.0
dcvz
 
Posts: 198
Joined: Tue Apr 15, 2008 12:02 am

Re: "very high topography" problem with running real.exe

Postby lmkli » Wed Jan 22, 2020 10:00 pm

Thank you for the suggestion. I will try to find the proper eta_levels if possible.
lmkli
 
Posts: 4
Joined: Tue Feb 03, 2009 5:51 pm


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 7 guests