Page 1 of 1

WRF4.2 FSBM code gives compile errors with PGI 19.10

PostPosted: Wed May 20, 2020 3:59 pm
by twtesche
Building WRF4.2 on PGI 19.10 (smpar) fails trying to compile 'module_mp_SBM_polar_radar.F'. The error message is ...

PGF90-S-0038-Symbol, derf, has not been explicitly declared (module_mp_SBM_polar_radar.f90)
0 inform, 0 warnings, 1 severes, 0 fatal for calc_dc_wet_snow
Command exited with non-zero status 2
0.32user 0.02system 0:00.36elapsed 95%CPU (0avgtext+0avgdata 11352maxresident)k
0inputs+8192outputs (0major+2215minor)pagefaults 0swaps
make[3]: [../configure.wrf:353: module_mp_SBM_polar_radar.o] Error 2 (ignored)

While the Release Notes for WRF4.2 state that "The FAST SBM code is not currently configured to work with default 8-byte reals," it is unclear if there is a work around for this.

The issue seems to be with the double-precision error function (derf) treatment in 'module_mp_SBM_polar_radar.F' at line 1538.
I've tried compiling with PGI llvm and nollvm to no avail.
Any thoughts with this? Thanks!