WPS Geogrid terminating without any error message

Nesting issues in WPS

WPS Geogrid terminating without any error message

Postby dileepkunjaai » Sun Nov 08, 2020 1:55 pm

Dear all,

I am trying to run WPS with a nested (2 domains) setting. But while running geogrid.exe, the process terminating without any error message. The geogrid.log file contains the only one line
020-11-08 11:37:57.481 --- *** Starting program geogrid.exe ***
after this line, nothing is showing.

I am running WRF on CRAy-XC 40 computer. I have attached my jobscript and namelist.wps along with this mail. I can run everything correctly with a single domain case, but the nested domain only has this issue.

Sincerely,

Dileepkumar R

Code: Select all
&share
 wrf_core = 'ARW',
 max_dom = 2,
 start_date = '2002-12-15_06:00:00','2002-12-15_06:00:00'
 end_date   = '2002-12-30_06:00:00','2002-12-30_06:00:00'
 !start_date = '1989-01-01_12:00:00', '1989-01-01-12:00:00',
 !end_date   = '1989-01-01_12:00:00', '1989-01-01-12:00:00',
 interval_seconds = 21600
 io_form_geogrid = 2,
/

&geogrid
 parent_id         =   1,   1,
 parent_grid_ratio =   1,   3,
 i_parent_start    =   1,  54,
 j_parent_start    =   1,  60,
 e_we              =  153, 139,
 e_sn              =  172, 160,
 !
 !!!!!!!!!!!!!!!!!!!!!!!!!!!! IMPORTANT NOTE !!!!!!!!!!!!!!!!!!!!!!!!!!!!
 ! The default datasets used to produce the MAXSNOALB and ALBEDO12M
 ! fields have changed in WPS v4.0. These fields are now interpolated
 ! from MODIS-based datasets.
 !
 ! To match the output given by the default namelist.wps in WPS v3.9.1,
 ! the following setting for geog_data_res may be used:
 !
 ! geog_data_res = 'maxsnowalb_ncep+albedo_ncep+default', 'maxsnowalb_ncep+albedo_ncep+default',
 !
 !!!!!!!!!!!!!!!!!!!!!!!!!!!! IMPORTANT NOTE !!!!!!!!!!!!!!!!!!!!!!!!!!!!
 !
 geog_data_res = 'default', 'default',
 dx = 9000,  3000,
 dy = 9000,  3000,
 map_proj = 'mercator',
 ref_lat   = 12.972,
 ref_lon   = 77.594,
 truelat1  = 12.972,
 truelat2  = 0
 stand_lon = 78.552,
 geog_data_path = '/mnt/lustre/icw/icwravi/BuildWRF/WRF/intel/17.0.4/geog/',
/

&ungrib
 out_format = 'WPS',
 prefix = 'SFC',
 !prefix = 'PL',
 !prefix = 'FIX',
 !prefix = 'FILE',
/

&metgrid
 fg_name = 'PL','SFC',
 !fg_name='FILE'
 constants_name = 'FIX:1989-01-01_12', 'QNWFA_QNIFA_SIGMA_MONTHLY.dat',
 io_form_metgrid = 2,
 opt_output_from_metgrid_path = '/mnt/lustre/icw/icwravi/WRF3.9.1/test/em_real/',
 !opt_output_from_metgrid_path = '/mnt/lustre/icw/icwravi/II-WRF3.9.1/WRFV3/test/em_real/',
/

&mod_levs
 press_pa =  100000 , 95000 ,  90000 ,
             85000 ,  80000 ,
             75000 ,  70000 ,
             65000 ,  60000 ,
             55000 ,  50000 ,
             45000 ,  40000 ,
             35000 ,  30000 ,
             25000 ,  20000 ,
             15000 ,  10000 ,
              5000 ,   1000
 /



The job scrit for running geogrid.exe in CRAY-XC40 as follows:

Code: Select all
#!/bin/sh
#PBS -l accelerator_type="None"
#PBS -N wps9Km
#PBS -l select=1:ncpus=24
#PBS -l walltime=00:30:00
#PBS -l place=scatter
#PBS -S /bin/sh@sdb -V

 . /opt/modules/default/init/sh

cd $PBS_O_WORKDIR

module load pbs
module switch PrgEnv-cray/6.0.5 PrgEnv-intel
module load craype-haswell
module load cray-netcdf/4.6.3.1

export CRAYPE_LINK_TYPE=dynamic
export NETCDF=/opt/cray/pe/netcdf/4.6.3.1/INTEL/19.0
export JASPERINC=/mnt/lustre/icw/icwravi/BuildWRF/WRF/intel/17.0.4/ERA_intrim/LIBRARIES/grib2/include
export JASPERLIB=/mnt/lustre/icw/icwravi/BuildWRF/WRF/intel/17.0.4/ERA_intrim/LIBRARIES/grib2/lib
export WRFIO_NCD_LARGE_FILE_SUPPORT=1
#ls geogrid/GEOGRID.TBL
aprun -n 1 -N 1 ./geogrid.exe
dileepkunjaai
 
Posts: 6
Joined: Tue Feb 12, 2019 11:58 pm
Location: Bangalore India

Return to Nesting

Who is online

Users browsing this forum: No registered users and 1 guest

cron