Page 1 of 1

vert_refine_method in ndown WRFv4.2

PostPosted: Thu Dec 10, 2020 6:24 pm
by hawbecke
I am trying to run an additional nest using ndown and 1 km mesoscale for a 25 m LES with WRFv4.2 but am having issues with vertical refinement in ndown.

I first ran WPS with 4 domains (3 that will be my mesoscale runs, 1 that will be the LES) with vert_refine_method = 0,0,0,2, and specified eta_levels for each domain:

eta_levels(1:60) = [60 levels]
eta_levels(61:120) = [same 60 levels]
eta_levels(121:180) = [same 60 levels]
eta_levels(181:369) = [188 levels]

WPS finished cleanly and I ran real.exe for all domains and wrf.exe for the first 3 domains.

I then deleted the first 2 columns in all max_dom variables of namelist.input to get d03 and d04 to become d01 and d02, respectively. The new d01 has 60 levels and d02 with 188 (I verified that wrfinput_d04 has 188 levels).

I renamed wrfinput_d04 to wrfndi_d02, and renamed the wrfout_d03* files to wrfout_d01*. I then ran ndown with vert_refine_method = 0,2, and the eta_levels defined for both domains. Ndown ran cleanly and produced wrfinput_d02 and wrfbdy_d02.

Output for wrfinput_d02 only has 60 levels (expecting 188). The eta levels correspond to the same as d01, but the heights now correspond to the first 60 levels of the 188 level domain.

I am not very familiar with ndown, but from what I've seen on the threads, there have been some other issues from 4.0 with the hybrid option. I am not specifying hybrid_opt in the namelist, so I assume it is using option 2.

Re: vert_refine_method in ndown WRFv4.2

PostPosted: Thu Jan 07, 2021 1:45 pm
by ycy
Hi, I came across the same problem. Have you solved it?