metgrid.exe error GFS FV3 transition

Any issues with the actual running of the WRF.

metgrid.exe error GFS FV3 transition

Postby samuel2008 » Thu Jun 13, 2019 6:55 pm

Hi,

I've done my best to follow the instructions provided regarding running an older version of WRF with the new GFS FV3 model as input.

I've modified my num_metgrid_levels to 34 to be consistent with the new GFS, but am getting the following error during the run of metgrid.exe:

WRF_DEBUG: Warning DIM 4 , NAME num_metgrid_levels REDEFINED by var VV 35 34 in wrf_io.F90 line 2465

I've come across various information online about the above problem being due to 3D variables missing a surface value. However, I have yet to find a suitable solution. Wondering if anyone else has had this problem in particular with the new GFS.

Thank you,
Sam
samuel2008
 
Posts: 3
Joined: Fri May 31, 2019 2:04 pm

Re: metgrid.exe error GFS FV3 transition

Postby dcvz » Thu Jun 13, 2019 7:55 pm

Actually, that debug message is not an error, but a warning. The actual error is something different and occurs later.

To use the new GFS you need to run ungrib from WPSV4.0 or V.1. If you prefer, you can modify your older code with a 1-line change. Go to WPS/ungrib/src and edit rd_grib2.F. Search for "Pressure level (range" which is about line 752 and add the line in bold:
if(gfld%ipdtmpl(10).eq.100) then
! Pressure level (range from 1000mb to 0mb)
level=gfld%ipdtmpl(12) *
& (10. ** (-1. * gfld%ipdtmpl(11)))
if ( level .lt. pmin ) cycle MATCH_LOOP
elseif((gfld%ipdtmpl(10).eq.105).or.


and then recompile WPS. That line causes ungrib to skip levels above 10 mb.

The way the problem in metgrid was fixed was to filter out the troublesome levels in ungrib so that they are never passed on to metgrid.
dcvz
 
Posts: 183
Joined: Tue Apr 15, 2008 12:02 am

Re: metgrid.exe error GFS FV3 transition

Postby samuel2008 » Fri Jun 14, 2019 12:30 pm

Thank you for the prompt reply!!

Do you know if just overriding the binary executable ungrib.exe with that from WPS4.1 will suffice? I ask because I have a later version of WRF/WPS (4.1) compiled separately. If it's as easy as overriding the ungrib.exe executable with the new one I'd prefer to go that route for now and work towards getting the later version of WRF compiled in production at a later date.

Thanks again..

Sam
samuel2008
 
Posts: 3
Joined: Fri May 31, 2019 2:04 pm

Re: metgrid.exe error GFS FV3 transition

Postby gabrielcassol » Sat Jun 15, 2019 8:23 pm

samuel2008 wrote:Hi,

I've done my best to follow the instructions provided regarding running an older version of WRF with the new GFS FV3 model as input.

I've modified my num_metgrid_levels to 34 to be consistent with the new GFS, but am getting the following error during the run of metgrid.exe:

WRF_DEBUG: Warning DIM 4 , NAME num_metgrid_levels REDEFINED by var VV 35 34 in wrf_io.F90 line 2465

I've come across various information online about the above problem being due to 3D variables missing a surface value. However, I have yet to find a suitable solution. Wondering if anyone else has had this problem in particular with the new GFS.

Thank you,
Sam



Hello, Samuel! I just migrated to WRF 4.0.3 and also faced this same problem, I had to change the num_metgrid_levels from 32 to 34 on namelist.input, after doing that it ran normal!

But I was wondering if you also have to change the numtiles of namelist.input, because before I was with 32, my question is if you also have to change to 34 or leave quiet with 32 same? I tried running both 32 and 34 and ran normal!
gabrielcassol
 
Posts: 1
Joined: Sun Oct 14, 2018 5:25 pm
Location: Pelotas, State of Rio Grande do Sul, Brazil

Re: metgrid.exe error GFS FV3 transition

Postby dcvz » Mon Jun 17, 2019 2:37 am

Yes, that's all you need to do. Just use ungrib.exe from the WPS4.1 directory.
dcvz
 
Posts: 183
Joined: Tue Apr 15, 2008 12:02 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 4 guests