Segmentation fault (core dumped with real.exe

Any issues with the actual running of the WRF.

Segmentation fault (core dumped with real.exe

Postby Supanee_j » Thu Jun 06, 2019 5:15 am

i got this when i use ./real.exe

starting wrf task 0 of 1
Segmentation fault (core dumped)

in the error file it said;
taskid: 0 hostname: master
module_io_quilt_old.F 2931 T

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0 0x14fadc732ea7 in ???
#1 0x14fadc7320dd in ???
#2 0x14fadbdaef1f in ???
#3 0x14fadc80c500 in ???
#4 0x14fadc800c84 in ???
#5 0x14fadc803667 in ???
#6 0x14fadc803828 in ???
#7 0x555ef12e328d in ???


my namelist.input file;
&time_control
run_days = 30,
run_hours = 0,
run_minutes = 0,
run_seconds = 0,
start_year = 2020, 2020,
start_month = 01, 01,
start_day = 01, 01,
start_hour = 0, 0,
start_minute = 00, 00,
start_second = 00, 00,
end_year = 2020, 2020,
end_month = 01, 01,
end_day = 31, 31,
end_hour = 00, 00,
end_minute = 00, 00,
end_second = 00, 00,
interval_seconds = 21600,
input_from_file = .true., .true.,
history_interval = 180, 60,
frames_per_outfile = 1000, 1000,
restart = .false.,
restart_interval = 1440,
io_form_history = 2,
io_form_restart = 2,
io_form_input = 2,
io_form_boundary = 2,
io_form_auxinput4 = 2,
auxinput4_inname = "wrflowinp_d<domain>",
auxinput4_interval = 21600
io_form_auxinput4 = 2,
auxinput4_interval_s = 21600,
debug_level = 0,
/

&domains
time_step = 360,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 2,
e_we = 100, 61,
e_sn = 90, 118,
e_vert = 32, 32,
p_top_requested = 5000,
num_metgrid_levels = 27,
num_metgrid_soil_levels = 4,
dx = 60000, 20000,
dy = 60000, 20000,
grid_id = 1, 2,
parent_id = 1, 1,
i_parent_start = 1, 36,
j_parent_start = 1, 27,
parent_grid_ratio = 1, 3,
parent_time_step_ratio = 1, 3,
feedback = 1,
smooth_option = 0,
/

&physics
mp_physics = 3, 3,
ra_lw_physics = 1, 1,
ra_sw_physics = 1, 1,
radt = 30, 30,
sf_sfclay_physics = 1, 1,
sf_surface_physics = 2, 2,
bl_pbl_physics = 1, 1,
bldt = 0, 0,
cu_physics = 1, 1,
cudt = 5, 5,
isfflx = 1,
ifsnow = 0,
icloud = 1,
surface_input_source = 1,
num_soil_layers = 4,
sf_urban_physics = 0, 0,
maxiens = 1,
maxens = 3,
maxens2 = 3,
maxens3 = 16,
ensdim = 144,
sst_update = 1,
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1,
km_opt = 4,
diff_6th_opt = 0, 0,
diff_6th_factor = 0.12, 0.12,
base_temp = 290.,
damp_opt = 0,
zdamp = 5000., 5000.,
dampcoef = 0.2, 0.2,
khdif = 0, 0,
kvdif = 0, 0,
non_hydrostatic = .true., .true.,
moist_adv_opt = 1, 1,
scalar_adv_opt = 1, 1,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,
nested = .false., .true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/



i tried ulimit -s unlimited .....it did't work
I'm a new user, hope someone can help me fixing it\
Thank you
Supanee_j
 
Posts: 1
Joined: Thu Jun 06, 2019 4:44 am

Re: Segmentation fault (core dumped with real.exe

Postby jcanellas » Fri Jun 21, 2019 9:06 am

Dear colleague,

is this all the content of the rsl.error.0000 file?

in the error file it said;
taskid: 0 hostname: master
module_io_quilt_old.F 2931 T

If this is true, you could try re running with debug level = 50, and post the rsl.error.0000 file that is generated. This should help find the problem.
jcanellas
 
Posts: 8
Joined: Tue Jun 18, 2019 9:21 am
Location: Buenos Aires, Argentina


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 4 guests