./geogrid.exe problem

Any issues with the actual running of the WRF.

./geogrid.exe problem

Postby lslrsgis » Tue Nov 06, 2018 7:05 am

Dear WRF help,

I have met a ./geogrid.exe problem after installation.

When I am trying to run ./geogrid.exe within WPS after correctly establishing the geog_data_path, it cannot open the index file inside topo_gmted2010_30s. Information prompts as follows:

***@***-Vostro-3668:~/Downloads/WRF_Download/WPS$ ./geogrid.exe
Parsed 28 entries in GEOGRID.TBL
Processing domain 1 of 2
ERROR: Could not open ~/Downloads/WRF_Download/WPS_GEOG/WPS_GEOG_HIGH_RES/topo_gmted2010_30s/index
application called MPI_Abort(MPI_COMM_WORLD, 21978) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=21978
system msg for write_line failure : Bad file descriptor

-The version 4.0 WPS and WRF are successfully installed after setting the dependent libraries (jasper, PNG, zlib, NetCDF, NCL) and environment variables.
-High and low resolution Geographic Datasets are downloaded, and referenced in geog_data_path section of namelist.wps.
-smpar 33 (Linux+GNU+GRIB), and nesting 1 (basic) are chosen for installation
-The weird thing is that the index file does exist, and in the correct directory. I can even manually edit it.
***@***-Vostro-3668:~/Downloads/WRF_Download/WPS_GEOG/WPS_GEOG_HIGH_RES/topo_gmted2010_30s$ gedit index

Any indications?

Thank you,

Posts: 3
Joined: Sun Oct 28, 2018 11:56 am

Re: ./geogrid.exe problem

Postby kwthomas » Tue Nov 06, 2018 4:54 pm

Hi Domi...

The problem is that you used a tilde in your file name. You can't do that. Specify the full path.

The tildes are used for shortcuts to the shell (sh, csh, tsh, bash, etc). As a rule, programs don't
know what they are or what they mean.
Kevin W. Thomas
Center for Analysis and Prediction of Storms
University of Oklahoma
Posts: 279
Joined: Thu Aug 07, 2008 6:53 pm

Return to Runtime Problems

Who is online

Users browsing this forum: minwookim and 8 guests