Invalid domain: Problem running WRFV3

Any issues with the actual running of the WRF.

Invalid domain: Problem running WRFV3

Postby mactech » Tue Jan 02, 2018 6:17 am

Hello everybody!

My name is Sara and I'm installing WRF for my very first time. I managed to solve all errors I had to deal with until now, but I've been trying to run WRFV3 for days, with no success.

First of all, I'm running WRF in a 16.04 TLS Linux (64 bit), with a Intel Xeon CPU E5620 @ 2.4 GHz x 8 processor. I'm using WRF 3.9.1.1, and all steps I followed for compiling, preparing and running WPS were successful. I got my geo_em* and met_em* files correctly, saved in some folders I created, to keep everything organized.
My problem occurs when trying to run real.exe. I compiled WRF for real cases, so I start my simulation in ../WRFV3/test/em_real. After editing namelist.input according to the namelist.wps, I execute real.exe and I get this error:

-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 5465
invalid parent id for domain 2
-------------------------------------------


I don't know what happens... namelist.input and namelist.wps are attached bellow.

I can't find any references to this, and I've already tried re-compiling WRF and editing namelist.input., but I always get the same error.

Note: I'm just trying to make WRF work. I don't pretend to get relevant data. I only need to know everything works to start out trying simulations for actual data.

Thank you so much in advance, and hope you have such an amazing New Year!

namelist.wps
&share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2017-12-23_00:00:00','2017-12-23_00:00:00','2017-12-23_00:00:00',
end_date = '2017-12-24_18:00:00','2017-12-24_18:00:00','2017-12-24_18:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1, 2,
parent_grid_ratio = 1, 3, 3,
i_parent_start = 1, 31, 40,
j_parent_start = 1, 17,
e_we = 74, 112,
e_sn = 61, 97,
geog_data_res = 'default','default','default',
dx = 30000,
dy = 30000,
map_proj = 'lambert',
ref_lat = 39.637252,
ref_lon = -3.084630,
truelat1 = 30.0,
truelat2 = 60.0,
stand_lon = -3.00,
geog_data_path = '/home/../Build_WRF/WPS_GEOG/',
!opt_output_from_geogrid_path = '/home/../WRF/output/geogrid/',
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE',
io_form_metgrid = 2,
opt_output_from_metgrid_path = '/home/../WRF/output/metgrid/',
opt_metgrid_tbl_path = '/home/../WPS/metgrid/',
/


namelist.input
&time_control
run_days = 0,
run_hours = 42,
run_minutes = 0,
run_seconds = 0,
start_year = 2017, 2017, 2017,
start_month = 12, 12, 12,
start_day = 23, 23, 23,
start_hour = 00, 00, 00,
start_minute = 00, 00, 00,
start_second = 00, 00, 00,
end_year = 2017, 2017, 2017,
end_month = 12, 12, 12,
end_day = 24, 24, 23,
end_hour = 18, 18, 18,
end_minute = 00, 00, 00,
end_second = 00, 00, 00,
interval_seconds = 21600,21600,21600,
input_from_file = .true.,.true.,
history_interval = 180, 60, 60,
frames_per_outfile = 1000, 1000, 1000,
restart = .false.,
restart_interval = 5000,
io_form_history = 2,
io_form_restart = 2,
io_form_input = 2,
io_form_boundary = 2,
debug_level = 0,
/

&domains
time_step = 180,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 2,
e_we = 74, 112,
e_sn = 61, 97,
e_vert = 30, 30,
p_top_requested = 5000,
num_metgrid_levels = 32, 32, 32,
num_metgrid_soil_levels = 4, 4, 4,
dx = 3000, 100, 33.33,
dy = 3000, 100, 33.33,
grid_id = 1, 2, 3,
parent_id = 1, 1, 2,
i_parent_start = 1, 31, 40,
j_parent_start = 1, 17, 30,
parent_grid_ratio = 1, 3, 3,
parent_time_step_ratio = 1, 3, 3,
feedback = 1,
smooth_option = 0,
sfcp_to_sfcp = .true.,.true.,.true.,
/

&physics
physics_suite = 'CONUS'
radt = 30, 30, 30,
bldt = 0, 0, 0,
cudt = 5, 5, 5,
icloud = 1,
num_soil_layers = 4,
num_land_cat = 21,
sf_urban_physics = 0,
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1, 1, 1,
km_opt = 4, 4, 4,
diff_6th_opt = 0, 0, 0,
diff_6th_factor = 0.12, 0.12, 0.12,
base_temp = 290., 290,
damp_opt = 0,
zdamp = 5000., 5000., 5000.,
dampcoef = 0.2, 0.2, 0.2
khdif = 0, 0, 0,
kvdif = 0, 0, 0,
non_hydrostatic = .true.,.true.,
moist_adv_opt = 1, 1, 1,
scalar_adv_opt = 1, 1, 1,
gwd_opt = 1,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true.,.false.,.false.,
nested = .false.,.true.,.true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/
mactech
 
Posts: 2
Joined: Fri Dec 15, 2017 4:32 am

Re: Invalid domain: Problem running WRFV3

Postby mactech » Tue Jan 16, 2018 7:52 am

Please, this is very important. Can anyone give some help?
I have tried re-compiling and re-building both WPS and WRF, as well as modifying both namelist files, but it keeps showing the same error.

Thank you!
mactech
 
Posts: 2
Joined: Fri Dec 15, 2017 4:32 am


Return to Runtime Problems

Who is online

Users browsing this forum: Bing [Bot] and 5 guests