Error: not enough eta levels to reach p_top

Any issues with the actual running of the WRF.

Error: not enough eta levels to reach p_top

Postby jbasconcillo » Thu Aug 08, 2019 4:37 am

I cannot find how to go about this error.

#############################################
taskid: 0 hostname: hurricane
module_io_quilt_old.F 2931 T
Ntasks in X 1 , ntasks in Y 1
REAL_EM V4.1 PREPROCESSOR
*************************************
Parent domain
ids,ide,jds,jde 1 341 1 341
ims,ime,jms,jme -4 346 -4 346
ips,ipe,jps,jpe 1 341 1 341
*************************************
DYNAMICS OPTION: Eulerian Mass Coordinate
alloc_space_field: domain 1 , 3343815204 bytes allocated
d01 2013-11-01_12:00:00 Yes, this special data is acceptable to use: OUTPUT FROM METGRID V4.1
d01 2013-11-01_12:00:00 Input data is acceptable to use: met_em.d01.2013-11-01_12:00:00.nc
metgrid input_wrf.F first_date_input = 2013-11-01_12:00:00
metgrid input_wrf.F first_date_nml = 2013-11-01_12:00:00
d01 2013-11-01_12:00:00 Timing for input 0 s.
d01 2013-11-01_12:00:00 flag_soil_layers read from met_em file is 1
d01 2013-11-01_12:00:00 Turning off use of MAX WIND level data in vertical interpolation
d01 2013-11-01_12:00:00 Turning off use of TROPOPAUSE level data in vertical interpolation
Max map factor in domain 1 = 1.38. Scale the dt in the model accordingly.
Using sfcprs3 to compute psfc
d01 2013-11-01_12:00:00 You need one of four things:
d01 2013-11-01_12:00:00 1) More eta levels: e_vert
d01 2013-11-01_12:00:00 2) A lower p_top: p_top_requested
d01 2013-11-01_12:00:00 3) Increase the lowest eta thickness: dzbot
d01 2013-11-01_12:00:00 4) Increase the stretching factor: dzstretch_s or dzstretch_u
d01 2013-11-01_12:00:00 All are namelist options
-------------- FATAL CALLED ---------------
FATAL CALLED FROM FILE: <stdin> LINE: 7349
not enough eta levels to reach p_top
-------------------------------------------
[unset]: aborting job:
application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0
[unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=1
:
system msg for write_line failure : Bad file descriptor
[hurricane:mpi_rank_0][MPIDI_CH3_Abort] application called MPI_Abort(MPI_COMM_WORLD, 1) - process 0: Bad file descriptor (9)


#########################################namelist.input#################
&time_control
run_days = 12,
run_hours = 0,
run_minutes = 0,
run_seconds = 0,
start_year = 2013, 2013
start_month = 11, 11,
start_day = 01, 01,
start_hour = 12, 12,
end_year = 2013, 2013,
end_month = 11, 11,
end_day = 13, 13,
end_hour = 12, 12,
interval_seconds = 21600,
input_from_file = .true.,.false.,
history_interval = 180, 180,
frames_per_outfile = 1000, 1000,
restart = .false.,
restart_interval = 7200,
io_form_history = 2,
io_form_restart = 2,
io_form_input = 2,
io_form_boundary = 2,
debug_level = 0,
diag_print = 0,
/

&domains
time_step = 60,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 2,
e_we = 341, 331,
e_sn = 341, 331,
e_vert = 33, 33,
num_metgrid_levels = 27,
num_metgrid_soil_levels = 4,
dx = 18000, 6000,
dy = 18000, 6000,
p_top_requested = 1000,
grid_id = 1, 2,
parent_id = 0, 1,
i_parent_start = 1, 92,
j_parent_start = 1, 53,
parent_grid_ratio = 1, 3,
parent_time_step_ratio = 1, 3,
feedback = 1,
use_levels_below_ground = .false.,
ocean_levels = 30,
ocean_z
= 5., 15., 25., 35., 45., 55.,
65., 75., 85., 95., 105., 115.,
125., 135., 145., 155., 165., 175.,
185., 195., 210., 230., 250., 270.,
290., 310., 330., 350., 370., 390.

ocean_t = 302.3, 302.3, 302.3, 302.1, 301.9, 301.7,
301.2, 300.8, 300.1, 299.5, 298.7, 297.9,
291.1, 290.0, 288.7, 287.2, 285.7, 284.8,
284.0, 283.4, 283.0, 282.6, 282.2, 281.7

ocean_s = 34.0, 34.0, 34.0, 34.3, 34.3, 34.3,
34.3, 34.4, 34.4, 34.4, 34.4, 34.4,
34.6, 34.6, 34.7, 34.7, 34.7, 34.7,
34.7, 34.6, 34.6, 34.6, 34.6, 34.6,
34.6, 34.6, 34.6, 34.6, 34.6, 34.6,
vortex_interval = 15, 15,
max_vortex_speed = 30, 30,
corral_dist = 10, 10,
track_level = 5000,
time_to_move = 0., 0.,
/

&physics
mp_physics = 6, 6,
cu_physics = 1, 0,
ra_lw_physics = 1, 1,
ra_sw_physics = 1, 1,
bl_pbl_physics = 1, 1,
sf_sfclay_physics = 1, 1,
sf_surface_physics = 2, 2,
radt = 18, 18,
bldt = 0, 0,
cudt = 0, 0,
icloud = 1,
ifsnow = 0,
sf_urban_physics = 0, 0,
sf_ocean_physics = 2,
isftcflx = 2,
do_radar_ref = 1,
isfflx = 1,
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1, 1,
km_opt = 4, 4,
damp_opt = 0,
zdamp = 5000., 5000.,
dampcoef = 0.2, 0.2,
khdif = 0, 0,
kvdif = 0, 0,
non_hydrostatic = .true., .true.,
moist_adv_opt = 1, 1,
scalar_adv_opt = 1, 1,
/

&bdy_control
spec_bdy_width = 10,
spec_zone = 1,
relax_zone = 9,
specified = .true., .false.,
nested = .false., .true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/

############################namelist.wps##############

&share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2013-11-01_12:00:00','2013-11-01_12:00:00'
end_date = '2013-11-13_12:00:00','2013-11-13_12:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 3,
i_parent_start = 1, 92,
j_parent_start = 1, 53,
e_we = 341, 331,
e_sn = 341, 331,
geog_data_res = '5m','2m',
map_proj = 'mercator',
ref_lat = 25,
ref_lon = 130,
truelat1 = 25.0,
truelat2 = 0,
stand_lon = 135,
dx = 18000,
dy = 18000,
geog_data_path = '/home/joseph/models/WRF/Data/geog/WPS_GEOG'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
/
~
~
~
jbasconcillo
 
Posts: 20
Joined: Thu May 16, 2019 8:56 am

Re: Error: not enough eta levels to reach p_top

Postby BHajni » Sun Aug 11, 2019 2:45 pm

Hi,

The problem is that there is a failsafe in the model, not allowing too large vertical distances in the model. If I remember correctly for p_top=50 hPa you have to have around 35 levels, so for your 10 hPa you'll need much more. Follow the notes in the log:
1) More eta levels: e_vert or
2) A lower p_top: p_top_requested
I wouldn't recommend option 3 and personally I wouldn't play with option 4.

Cheers
BHajni
 
Posts: 37
Joined: Sun Mar 10, 2013 11:50 am

Re: Error: not enough eta levels to reach p_top

Postby jbasconcillo » Sun Aug 11, 2019 10:43 pm

Hi, thanks for your reply.

I found the issue and it is because of wrong dep_lib_path in the compilation of WRF. The model is now running.
jbasconcillo
 
Posts: 20
Joined: Thu May 16, 2019 8:56 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 10 guests

cron