wrf.exe Program received signal SIGSEGV: Segmentation fault

Any issues with the actual running of the WRF.

wrf.exe Program received signal SIGSEGV: Segmentation fault

Postby petroui » Mon Apr 16, 2018 5:51 am

Hi everyone,

I am trying to run wrf.exe with 5 domains i have a problem as it pasted in the in rsl.error.0000 below
Code: Select all
Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x7fe692689cc2
#1  0x7fe692688f90
#2  0x7fe691dba4af
#3  0x22461ed
#4  0x224ab2e
#5  0x224e831
#6  0x1ab1974
#7  0x1442cf2
#8  0xff0be5
#9  0xf156c8
#10  0x46392a
#11  0x405d53
#12  0x4058bc
#13  0x7fe691da582f
#14  0x4058f8
#15  0xffffffffffffffff


My namelist.input is :
Code: Select all
 &time_control
 run_days                            = 0,
 run_hours                           = 24,
 run_minutes                         = 0,
 run_seconds                         = 0,
 start_year                          = 2017, 2017, 2017, 2017, 2017,
 start_month                         = 12,   12,   12,   12,   12,
 start_day                           = 02,   02,   02,   02,   02,
 start_hour                          = 00,   00,   00,   00,   00,
 start_minute                        = 00,   00,   00,   00,   00,
 start_second                        = 00,   00,   00,   00,   00,
 end_year                            = 2017, 2017, 2017, 2017, 2017,
 end_month                           = 12,   12,   12,   12,   12,
 end_day                             = 03,   03,   03,   03,   03,
 end_hour                            = 00,   00,   00,   00,   00,
 end_minute                          = 00,   00,   00,   00,   00,
 end_second                          = 00,   00,   00,   00,   00,
 interval_seconds                    = 21600
 input_from_file                     = .true.,.true.,.true.,.true.,.true.,
 history_interval                    = 60,  60,   60,  60,  60,
 frames_per_outfile                  = 1000,  1000,   1000,  1000,  1000,
 restart                             = .false.,
 restart_interval                    = 5000,
 io_form_history                     = 2
 io_form_restart                     = 2
 io_form_input                       = 2
 io_form_boundary                    = 2
 debug_level                         = 0
 /

 &domains
 time_step                           = 60,
 time_step_fract_num                 = 0,
 time_step_fract_den                 = 1,
 max_dom                             = 5,
 e_we                                = 199, 229, 73, 55, 55,
 e_sn                                = 175, 175, 73, 55, 55,
 e_vert                              =  30,  30, 30, 30, 30,
 p_top_requested                     = 5000,
 num_metgrid_levels                  = 32,
 num_metgrid_soil_levels             = 4,
 dx                                  = 30000, 10000, 3333.33, 1111.11, 370.37,
 dy                                  = 30000, 10000, 3333.33, 1111.11, 370.37,
 grid_id                             = 1,     2,     3,       4,       5,   
 parent_id                           = 1,     1,     2,       3,       4,
 i_parent_start                      = 1,     66,    90,      35,      17,
 j_parent_start                      = 1,     58,    76,      35,      15,
 parent_grid_ratio                   = 1,     3,     3,       3,       3,
 parent_time_step_ratio              = 1,     3,     3,       3,       3,
 feedback                            = 0,
 smooth_option                       = 0
 /

 &physics
 mp_physics                          = 3,     3,     3,    3,   3,
 ra_lw_physics                       = 1,     1,     1,    1,   1,
 ra_sw_physics                       = 1,     1,     1,    1,   1,
 radt                                = 30,    30,    30,  30,  30,
 sf_sfclay_physics                   = 1,     1,     1,    1,   1,
 sf_surface_physics                  = 2,     2,     2,    2,   2,
 bl_pbl_physics                      = 1,     1,     1,    1,   1,
 bldt                                = 0,     0,     0,    0,   0,
 cu_physics                          = 1,     1,     0,    0,   0,
 cudt                                = 5,     5,     5,    5,   5,
 isfflx                              = 1,
 ifsnow                              = 1,
 icloud                              = 1,
 surface_input_source                = 3,
 num_soil_layers                     = 4,
 num_land_cat                        = 21,
 sf_urban_physics                    = 0,     0,     0,    0,   0,
 /

 &fdda
 /

 &dynamics
 w_damping                           = 0,
 diff_opt                            = 1,      1,      1,      1,      1,
 km_opt                              = 4,      4,      4,      4,      4,
 diff_6th_opt                        = 0,      0,      0,      0,      0,
 diff_6th_factor                     = 0.12,   0.12,   0.12,   0.12,   0.12,
 base_temp                           = 290.
 damp_opt                            = 0,
 zdamp                               = 5000.,  5000.,  5000.,  5000.,  5000.,
 dampcoef                            = 0.2,    0.2,    0.2,    0.2,    0.2,
 khdif                               = 0,      0,      0,      0,      0,
 kvdif                               = 0,      0,      0,      0,      0,
 non_hydrostatic                     = .true., .true., .true., .true., .true.,
 moist_adv_opt                       = 1,      1,      1,      1,      1,
 scalar_adv_opt                      = 1,      1,      1,      1,      1,
 /

 &bdy_control
 spec_bdy_width                      = 5,
 spec_zone                           = 1,
 relax_zone                          = 4,
 specified                           = .true., .false.,.false.,false.,false.,
 nested                              = .false., .true., .true., .true., .true.,
 /

 &grib2
 /

 &namelist_quilt
 nio_tasks_per_group = 0,
 nio_groups = 1,
 /


Any suggestions or any advices about that?
Is there any problem with selections of domains?

Thank you very much in advance!!!
petroui
 
Posts: 8
Joined: Mon Mar 27, 2017 5:54 am

Re: wrf.exe Program received signal SIGSEGV: Segmentation fa

Postby Roberto » Tue Apr 17, 2018 1:04 pm

Hi petroui

Have you tried putting "ulimit -s unlimited" before starting to run the wrf.exe ??
Roberto
 
Posts: 2
Joined: Tue Apr 17, 2018 12:42 pm

Re: wrf.exe Program received signal SIGSEGV: Segmentation fa

Postby petroui » Fri Apr 20, 2018 5:51 am

Dear Roberto,
thank you very much for your reply.
I tried to use the command: ulimit -s unlimited but it didn't work.
I also tried to reduce the number of domains but i have the same results.
petroui
 
Posts: 8
Joined: Mon Mar 27, 2017 5:54 am


Return to Runtime Problems

Who is online

Users browsing this forum: Google [Bot], Majestic-12 [Bot] and 6 guests