Fatal Error: Can't open module file 'module_initialize_ideal

Post here if you think you might have found any type of bug

Fatal Error: Can't open module file 'module_initialize_ideal

Postby pattim » Sat May 04, 2013 6:08 pm

I think I found a bug with v3.5.0 in the parallel build option(s) - I don't recall it being a problem in 3.4.1 but I'm not sure. I have a 6 CPU, single socket, Phenom II black computer. The compile process, even though the paths are set correctly, can't find a module it needs if you use "too many" CPUs during the build. I know one (-j 1) builds OK, but (-j 2), or more, fails.

(Note 2/3rds of the way down in the following code the error :"Can't open module file 'module_initialize_ideal.mod' for reading at (1)")

Code: Select all
/WRFV3> ./clean -a && ./configure
/WRFV3> ./compile -j 2 em_tropical_cyclone >& Compile_05-04-2013_TropCyclone.txt
        specified in shell environment....
copying Registry/Registry.EM to Registry/Registry
Compiling: WRF_EM_CORE .
setting parallel make -j 4
make -i -r MODULE_DIRS="-I../dyn_em -I../dyn_nmm   -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/esmf_time_f90  -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/main -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_netcdf -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_int -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/frame -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/share -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/phys -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/chem -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/inc -I/usr/local/netcdf363/include " ext
make[1]: Entering directory `/home/patti/00_GCMs/WRF/v3.5.0/WRFV3'


mpif90 -f90=gfortran -o ../dyn_em/module_initialize_tropical_cyclone.o -c -O2 -ftree-vectorize -funroll-loops -w -ffree-form -ffree-line-length-none -fconvert=big-endian -frecord-marker=4   -I../dyn_em -I../dyn_nmm   -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/esmf_time_f90  -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/main -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_netcdf -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_int -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/frame -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/share -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/phys -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/chem -I/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/inc -I/usr/local/netcdf363/include    ../dyn_em/module_initialize_tropical_cyclone.f90

   USE module_initialize_ideal
Fatal Error: Can't open module file 'module_initialize_ideal.mod' for reading at (1): No such file or directory
make[1]: [ideal_em.o] Error 1 (ignored)
ranlib libwrflib.a
mpif90 -f90=gfortran -o ideal.exe  -O2 -ftree-vectorize -funroll-loops -w -ffree-form -ffree-line-length-none -fconvert=big-endian -frecord-marker=4    ideal_em.o ../dyn_em/module_initialize_tropical_cyclone.o libwrflib.a /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/fftpack/fftpack5/libfftpack.a /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_grib1/libio_grib1.a /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_grib_share/libio_grib_share.a /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_int/libwrfio_int.a -L/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/esmf_time_f90 -lesmf_time /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/RSL_LITE/librsl_lite.a /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/frame/module_internal_header_util.o /home/patti/00_GCMs/WRF/v3.5.0/WRFV3/frame/pack_utils.o  -L/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/external/io_netcdf -lwrfio_nf -L/usr/local/netcdf363/lib  -lnetcdf     
gfortran: error: ideal_em.o: No such file or directory
make[1]: [em_ideal] Error 1 (ignored)
make[1]: Leaving directory `/home/patti/00_GCMs/WRF/v3.5.0/WRFV3/main'
( cd test/em_tropical_cyclone ; /bin/rm -f wrf.exe ; ln -s ../../main/wrf.exe . )
( cd test/em_tropical_cyclone ; /bin/rm -f ideal.exe ; ln -s ../../main/ideal.exe . )
( cd test/em_tropical_cyclone ; /bin/rm -f README.namelist ; ln -s ../../run/README.namelist . )
( cd run ; /bin/rm -f ideal.exe ; ln -s ../main/ideal.exe . )
( cd run ; if test -f namelist.input ; then \
   /bin/cp -f namelist.input namelist.input.backup ; fi ; \
   /bin/rm -f namelist.input ; ln -s ../test/em_tropical_cyclone/namelist.input . )
( cd run ; /bin/rm -f input_sounding ; ln -s ../test/em_tropical_cyclone/input_sounding . )
build started:   Sat May  4 14:49:50 PDT 2013
build completed: Sat May 4 15:00:05 PDT 2013

The directory (main) is there, but apparently the "missing" .mod file isn't there at the right time... (because it is there when I view the directory). Did I just miss this as a known bug with multithreaded compiling?
Posts: 13
Joined: Fri Jul 27, 2012 11:29 am

Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest