error running geogrid.exe WRF 3.7 version

Having problems running the WRF Preprocessing Sysmte (WPS)?

error running geogrid.exe WRF 3.7 version

Postby lefteris » Sun Jun 21, 2015 4:53 am

Hi guys,

I am trying the brand new WRF version I have successfully compile all prerequisites but with geogrid I am getting the following error

At line 142 of file gridinfo_module.f90 (unit = 10, file = 'namelist.wps')
Fortran runtime error: End of file

I also have dived in gridinfo_module.f90

! Read parameters from Fortran namelist
do funit=10,100
inquire(unit=funit, opened=is_used)
if (.not. is_used) exit
end do
open(funit,file='namelist.wps',status='old',form='formatted',err=1000)
read(funit,share)
read(funit,geogrid)
close(funit)

I am posting also namelist.wps

share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2006-08-16_12:00:00','2006-08-16_12:00:00',
end_date = '2006-08-16_18:00:00','2006-08-16_12:00:00',
interval_seconds = 21600
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 3,
i_parent_start = 1, 31,
j_parent_start = 1, 17,
e_we = 74, 112,
e_sn = 61, 97,
geog_data_res = '10m','2m',
dx = 30000,
dy = 30000,
map_proj = 'lambert',
ref_lat = 34.83,
ref_lon = -81.03,
truelat1 = 30.0,
truelat2 = 60.0,
stand_lon = -98.0,
geog_data_path = '/home/Build_WRF/WPS_GEOG'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE',
io_form_metgrid = 2,
/

Please could you help me on that stage ?
lefteris
 
Posts: 2
Joined: Sun Jun 21, 2015 4:45 am

Re: error running geogrid.exe WRF 3.7 version

Postby lefteris » Sun Jun 21, 2015 5:42 pm

It looks like I have corrected the issue,

now I am getting the following :

*** Starting program ungrib.exe ***
ERROR STOP IN READ_NAMELIST
INTERVAL must fit evenly between start time and end time:
Start time: 2015-06-21_00:00:00
End time: 2015-06-21_03:00:00
INTERVAL : 21600 seconds, 6.000000 hours
ERROR: Change your namelist, and resubmit

and my settings in nameless is the following. What is going on, with it ?

&share
wrf_core = 'ARW',
max_dom = 1,
start_date = '2015-06-21_00:00:00',
end_date = '2015-06-21_03:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 3,
i_parent_start = 1, 31,
j_parent_start = 1, 17,
e_we = 74, 112,
e_sn = 61, 97,
geog_data_res = '10m','2m',
dx = 30000,
dy = 30000,
map_proj = 'lambert',
ref_lat = 34.83,
ref_lon = -81.03,
truelat1 = 30.0,
truelat2 = 60.0,
stand_lon = -98.0,
geog_data_path = '/home/Build_WRF/WPS_GEOG'
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
/
lefteris
 
Posts: 2
Joined: Sun Jun 21, 2015 4:45 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 3 guests

cron