Missing file geogrid.exe metgrid.exe when compile Ifort+gcc

Having problems running the WRF Preprocessing Sysmte (WPS)?

Missing file geogrid.exe metgrid.exe when compile Ifort+gcc

Postby phamhoanganh01 » Sat May 18, 2019 6:17 am

Dear sir/Madam

I am a student of Meteorology - Faculty of Hydrology, Meteorology and Oceanography
VNU - University of Sience. So I get a problem with my English.

My supercomputer in University only have Ifort and gcc and I do not have root access to install gfortran. So I edit file configure_new.defaults in WRF/arch
and It runs successfully with:
wrf.exe
real.exe
ndown.exe
tc.exe

but in WPS I do the same then WPS only make file ungrib.exe
Here was my file edited



#############################################################
#ARCH Linux x86_64, Intel Ifort compiler with Gcc moding by H.anh K60 contact_0988342406 # serial serial_NO_GRIB2 dmpar dmpar_NO_GRIB2
#
COMPRESSION_LIBS = CONFIGURE_COMP_L
COMPRESSION_INC = CONFIGURE_COMP_I
FDEFS = CONFIGURE_FDEFS
SFC = ifort
SCC = gcc
DM_FC = mpif90 -f90=ifort
DM_CC = mpicc -cc=gcc
FC = CONFIGURE_FC
CC = CONFIGURE_CC
LD = $(FC)
FFLAGS = -FR -convert big_endian
F77FLAGS = -FI -convert big_endian
FCSUFFIX =
FNGFLAGS = $(FFLAGS)
LDFLAGS =
CFLAGS = -w
CPP = /lib/cpp -P -traditional
CPPFLAGS = -D_UNDERSCORE -DBYTESWAP -DLINUX -DIO_NETCDF -DIO_BINARY -DIO_GRIB1 -DBIT32 CONFIGURE_MPI
ARFLAGS =
CC_TOOLS =
##################################################################

Does Any one Help me. I remember in the past it did run successfully, but now it does not work

here is my ~/.bashrc

####################################################################
# User specific aliases and functions
PATH="/opt/apps_intel_11.1/netcdf/bin:$PATH"
PATH="/opt/app_intel_11.1/intel11.1/Compiler/11.1/080/bin/:$PATH"
PATH="/opt/apps_intel_11.1/mpich2/bin:$PATH"
# Install WRF-chem
export CC="gcc"
export CXX="g++"
export F77="/opt/apps_intel_11.1/intel11.1/Compiler/11.1/080/bin/intel64/ifort"
export FC="/opt/apps_intel_11.1/intel11.1/Compiler/11.1/080/bin/intel64/ifort"
export FFLAGS="-m64"
export FCFLAGS="-m64"
export DIR="/home/cosmo/tmp/hoanganh/Build_WRF/LIBRARIES"
export PATH="$DIR/netcdf/bin:$PATH"
export NETCDF="$DIR/netcdf"
export PATH="$DIR/mpich/bin:$PATH"
export LDFLAGS="-L$DIR/grib2/lib"
export CPPFLAGS="-I$DIR/grib2/include"
export JASPERLIB="$DIR/grib2/lib"
export JASPERINC="$DIR/grib2/include"

#WRF_Chem Flex Yacc
export WRF_EM_CORE=1
export WRF_NMM_CORE=0
export WRF_CHEM=1
export WRFIO_NCD_LARGE_FILE_SUPPORT=1
export HDF5=${DIR}/HDF5
export PATH=$HDF5/bin:$PATH
export PATH="$DIR/yacc:$PATH"
export PATH="$DIR/flex/bin:$PATH"
export YACC=$DIR/yacc
export FLEX="$DIR/flex/bin/flex"
export FLEX_LIB_DIR="$DIR/flex/lib"
#export WRF_KPP=0
########################################################################
phamhoanganh01
 
Posts: 3
Joined: Fri May 17, 2019 1:19 am

Re: Missing file geogrid.exe metgrid.exe when compile Ifort+

Postby zayfin » Tue Jul 23, 2019 10:27 am

i got a lot of error when i compiled WPS. but i did not get any error while compiling the WRF.
i solve the problems with the editing the confiruge.wps with correct options.
i changed the these flags : SFC , SCC, DM_FC, DM_CC .

and look at your optimization flags!
i use O2
zayfin
 
Posts: 13
Joined: Wed Nov 03, 2010 10:48 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 3 guests