metgrid.exe hangs forever

Having problems running the WRF Preprocessing Sysmte (WPS)?

metgrid.exe hangs forever

Postby jaymtee » Thu Jul 13, 2017 5:50 pm

I am trying to run WRF (v3.9) in three nested domains as shown below. (Note that this all seemed to work yesterday before I started tuning the domain areas, dx, dy, and times.) When I get to run metgrid.exe, it seemingly hangs forever with the output in metgrid.log being:
************************************************

2017-07-13 16:23:21.158 --- *** Starting program metgrid.exe ***
2017-07-13 16:23:21.158 --- Using the following namelist variables:
2017-07-13 16:23:21.158 --- &SHARE
2017-07-13 16:23:21.158 --- WRF_CORE = ARW
2017-07-13 16:23:21.158 --- MAX_DOM = 3
2017-07-13 16:23:21.158 --- START_YEAR = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- START_MONTH = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- START_DAY = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- START_HOUR = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- = 0
2017-07-13 16:23:21.158 --- START_MINUTE = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- START_SECOND = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_YEAR = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_MONTH = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_DAY = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_HOUR = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_MINUTE = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- END_SECOND = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- = 0
2017-07-13 16:23:21.159 --- START_DATE = 2011-04-25_06:00:00
2017-07-13 16:23:21.159 --- = 2011-04-25_06:00:00
2017-07-13 16:23:21.160 --- = 2011-04-25_06:00:00
2017-07-13 16:23:21.160 --- END_DATE = 2011-04-26_00:00:00
2017-07-13 16:23:21.160 --- = 2011-04-26_00:00:00
2017-07-13 16:23:21.160 --- = 2011-04-26_00:00:00
2017-07-13 16:23:21.160 --- INTERVAL_SECONDS = 21600
2017-07-13 16:23:21.160 --- IO_FORM_GEOGRID = 2
2017-07-13 16:23:21.160 --- OPT_OUTPUT_FROM_GEOGRID_PATH = ./
2017-07-13 16:23:21.160 --- SUBGRID_RATIO_X = 1
2017-07-13 16:23:21.160 --- = 1
2017-07-13 16:23:21.160 --- = 1
2017-07-13 16:23:21.160 --- SUBGRID_RATIO_Y = 1
2017-07-13 16:23:21.160 --- = 1
2017-07-13 16:23:21.160 --- = 1
2017-07-13 16:23:21.160 --- DEBUG_LEVEL = 0
2017-07-13 16:23:21.160 --- ACTIVE_GRID = .TRUE.
2017-07-13 16:23:21.160 --- = .TRUE.
2017-07-13 16:23:21.160 --- = .TRUE.
2017-07-13 16:23:21.160 --- NOCOLONS = .FALSE.
2017-07-13 16:23:21.160 --- /
2017-07-13 16:23:21.160 --- &METGRID
2017-07-13 16:23:21.160 --- FG_NAME = FILE
2017-07-13 16:23:21.160 --- CONSTANTS_NAME =
2017-07-13 16:23:21.160 --- IO_FORM_METGRID = 2
2017-07-13 16:23:21.160 --- PROCESS_ONLY_BDY = 0
2017-07-13 16:23:21.160 --- OPT_OUTPUT_FROM_METGRID_PATH = ./
2017-07-13 16:23:21.161 --- OPT_METGRID_TBL_PATH = metgrid/
2017-07-13 16:23:21.161 --- /
2017-07-13 16:23:21.164 --- Processing domain 1 of 3
2017-07-13 16:23:21.164 --- Initializing storage module
2017-07-13 16:23:21.164 --- Opening static input file.
2017-07-13 16:23:21.165 --- Reading static global attributes.

*************************************************
My namelist.wps is as follows:
*************************************************
&share
wrf_core = 'ARW',
max_dom = 3,
start_date = '2011-04-25_06:00:00', '2011-04-25_06:00:00', '2011-04-25_06:00:00',
end_date = '2011-04-25_12:00:00', '2011-04-25_12:00:00', '2011-04-25_12:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
/

&geogrid
parent_id = 1,1,2,
parent_grid_ratio = 1,3,3,
i_parent_start = 1,150,200,
j_parent_start = 1,32,70,
e_we = 400,601,1000,
e_sn = 250,400,601,
geog_data_res = '30s','30s','30s',
dx = 0.09,
dy = 0.1135,

map_proj = 'lat-lon',
ref_lat = 38,
ref_lon = -90,
truelat1 = 38,
truelat2 = 38,
stand_lon = -90,
geog_data_path = '/home/jt2/Build_WRF/WPS/WPS_GEOG/'
pole_lat = 90,
pole_lon = 180,
/

&ungrib
out_format = 'WPS',
prefix = 'FILE',
/

&metgrid
fg_name = 'FILE'
io_form_metgrid = 2,
/
jaymtee
 
Posts: 5
Joined: Tue Aug 23, 2016 11:20 am

Re: metgrid.exe hangs forever

Postby jaymtee » Thu Jul 13, 2017 7:04 pm

The error seems to be in set_domain_projection, from which I never return!

Any clues?
jaymtee
 
Posts: 5
Joined: Tue Aug 23, 2016 11:20 am


Return to Runtime Problems

Who is online

Users browsing this forum: No registered users and 1 guest