Page 1 of 1

Read if you compiled a newer version of Jasper

PostPosted: Thu Dec 08, 2016 7:51 pm
by JFMass
Hello all, while trying to compile WPS I was getting an error and ungrib would not be created.

The error was happening in file enc_jpeg2000.c on line 141:

Code: Select all
    image.inmem_=1;


After doing some searches I found that nmem_ attribute doesn't exist anymore in newer jasper libs so I think it would be a good idea to either comment out this line in future versions or specify that it is important to use jasper 1.7 ant NOT 1.9 or 2.0.

Commenting the line actually worked for me and ungrib.exe was created.

Re: Read if you compiled a newer version of Jasper

PostPosted: Wed Jan 03, 2018 3:59 am
by jp2nyy
How and where did you edit it out since I am not too familiar with it. Also, I am using the Jasper given by this http://www2.mmm.ucar.edu/wrf/OnLineTuto ... torial.php