Nested Grid with NCEP2 Reanalysis

Discuss the nesting capability within the model itself and any problems you might have run into.

Nested Grid with NCEP2 Reanalysis

Postby klockesm » Tue Sep 21, 2010 3:16 pm

I am having problems running a nested grid with a case using the NCEP/DOE Reanalysis-II dataset. I have tried several different domains and I have played with many of the variables in the namelist files, but am still unable to get wrfout* files for the nested grid. When I run wrf.exe the parent domain produces wrfout* files, until the time approaches the time for the nested grid. This particular namelist setup has both grids running for the same time range, so I do not get any wrfout* files. The rsl* files indicate that the program stops when it calls input data for domain d02. The program continues to try and compile, but does not produce any output and does not indicate anything in the rsl files beyond that point. I think the problem may be an issue with how I am running the NCEP data through WPS, but I'm not sure. Any help would be much appreciated. Thanks!

&share
wrf_core = 'ARW',
max_dom = 2,
start_date = '2008-01-14_18:00:00','2008-01-14_18:00:00',
end_date = '2008-01-16_06:00:00','2008-01-16_06:00:00',
interval_seconds = 21600,
io_form_geogrid = 2,
/

&geogrid
parent_id = 1, 1,
parent_grid_ratio = 1, 3,
i_parent_start = 1, 47,
j_parent_start = 1, 69,
e_we = 130, 19,
e_sn = 124, 19,
geog_data_res = '2m','30s'
dx = 9000,
dy = 9000,
map_proj = 'mercator',
ref_lat = 19.252,
ref_lon = -155.291,
truelat1 = 19.252,
truelat2 = 0,
stand_lon = -155.291,
geog_data_path = '/ptmp/klockesm/geog'
/

&ungrib
out_format = 'WPS',
prefix = 'FLXFILE',
/

&metgrid
fg_name = 'FLXFILE','PGBFILE',
io_form_metgrid = 2,
/



&time_control
run_days = 0,
run_hours = 24,
run_minutes = 0,
run_seconds = 0,
start_year = 2008, 2008,
start_month = 01, 01,
start_day = 15, 15,
start_hour = 0, 0,
start_minute = 00, 00,
start_second = 00, 00,
end_year = 2008, 2008,
end_month = 01, 01,
end_day = 16, 16,
end_hour = 0, 0,
end_minute = 00, 00,
end_second = 00, 00,
interval_seconds = 21600,
input_from_file = .true., .true.,
history_interval = 180, 60,
frames_per_outfile = 1000, 1000,
restart = .false.,
restart_interval = 5000,
io_form_history = 2,
io_form_restart = 2,
io_form_input = 2,
io_form_boundary = 2,
debug_level = 100,
/

&domains
time_step = 18,
time_step_fract_num = 0,
time_step_fract_den = 1,
max_dom = 2,
e_we = 130, 19,
e_sn = 124, 19,
e_vert = 28, 28,
p_top_requested = 5000,
num_metgrid_levels = 18,
num_metgrid_soil_levels = 2,
dx = 9000, 3000,
dy = 9000, 3000,
grid_id = 1, 2,
parent_id = 0, 1,
i_parent_start = 1, 47,
j_parent_start = 1, 69,
parent_grid_ratio = 1, 3,
parent_time_step_ratio = 1, 3,
feedback = 1,
smooth_option = 0,
/

&physics
mp_physics = 3, 3,
ra_lw_physics = 1, 1,
ra_sw_physics = 1, 1,
radt = 9, 3,
sf_sfclay_physics = 2, 0,
sf_surface_physics = 2, 0,
bl_pbl_physics = 2, 0,
bldt = 0, 0,
cu_physics = 1, 0,
cudt = 5, 5,
isfflx = 1,
ifsnow = 0,
icloud = 1,
surface_input_source = 1,
num_soil_layers = 4,
sf_urban_physics = 0, 0,
maxiens = 1,
maxens = 3,
maxens2 = 3,
maxens3 = 16,
ensdim = 144,
/

&fdda
/

&dynamics
w_damping = 0,
diff_opt = 1,
km_opt = 4,
diff_6th_opt = 0, 0,
diff_6th_factor = 0.12, 0.12,
base_temp = 290.,
damp_opt = 0,
zdamp = 5000., 5000.,
dampcoef = 0.2, 0.2,
khdif = 0, 0,
kvdif = 0, 0,
non_hydrostatic = .true., .true.,
moist_adv_opt = 1, 1,
scalar_adv_opt = 1, 1,
/

&bdy_control
spec_bdy_width = 5,
spec_zone = 1,
relax_zone = 4,
specified = .true., .false.,
nested = .false., .true.,
/

&grib2
/

&namelist_quilt
nio_tasks_per_group = 0,
nio_groups = 1,
/
klockesm
 
Posts: 2
Joined: Wed Sep 01, 2010 4:35 pm

Re: Nested Grid with NCEP2 Reanalysis

Postby klockesm » Wed Sep 29, 2010 3:14 pm

This turned out to be a problem with my WRF compile. Apparently, this was a problem that only showed up when I ran WRF for a nested grid with NCEP/DOE Reanalysis-II data. Any other data that I used for initial conditions worked fine. Also, the NCEP2 data worked fine for one parent domain and one only. I ended up re-compiling WRF and had no more problems.
klockesm
 
Posts: 2
Joined: Wed Sep 01, 2010 4:35 pm

Re: Nested Grid with NCEP2 Reanalysis

Postby dmoreno1 » Tue Jun 14, 2011 6:42 am

Hi,

I have the same problem, running WRF 3.3 with reanalysis II with 4 nested domains. I tried to recompile WRF, but I keep having the same problem as you!!

Can you describe me what was the compilation problem??

Thank you!!
dmoreno1
 
Posts: 32
Joined: Thu Apr 16, 2009 10:13 am


Return to Nesting

Who is online

Users browsing this forum: No registered users and 1 guest

cron